This project has moved and is read-only. For the latest updates, please go here.

Error

May 27, 2015 at 3:26 AM
Hi,
I am really interested in your module, so I tried it.
But unfortunately, once I install a template I have this error :

ERROR BEGIN
Internal Server Error : {"Message":"An error has occurred.","ExceptionMessage":"Could not find a part of the path 'C:\inetpub\wwwroot\Portals\1\OpenForm\Templates\Contact\schema.json'.","ExceptionType":"System.IO.DirectoryNotFoundException","StackTrace":" at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)\r\n at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)\r\n at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)\r\n at System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize, Boolean checkHost)\r\n at System.IO.File.InternalReadAllText(String path, Encoding encoding, Boolean checkHost)\r\n at Satrabel.OpenForm.Components.OpenFormAPIController.Form()"}
ERROR END

In ny case the path is : C:\inetpub\wwwroot\__DNN731__\\Portals\1\OpenForm\Templates\Contact\schema.json

It only works for website directly install on wwwroot ?

On the documentation tab, you wrote :
3) Add the OpenContent module to a page.

Shoulb be : 3) Add the OpenForm module to a page, no ?

Regards.
Antoine.
Jun 8, 2015 at 2:13 PM
Hi,

In ny case the path is : C:\inetpub\wwwroot__DNN731__\\Portals\1\OpenForm\Templates\Contact\schema.json
It only works for website directly install on wwwroot ?
No.
Do import the template ?
Does "C:\inetpub\wwwroot__DNN731__\\Portals\1\OpenForm\Templates\Contact\schema.json" the file and directory exist on your system ?

On the documentation tab, you wrote :
3) Add the OpenContent module to a page. Shoulb be : 3) Add the OpenForm module to a page, no ?
You are rigth. I have correct it.
Sacha
Jul 8, 2015 at 10:22 AM
Hi,

I have upgraded openForm and openContent module. I don't have the error anymore, but I still don't able to set up a form.

I have downloaded the 2 forms you provide on http://www.openextensions.net

Once I have install a openForm module on a page, I choose a template and I click on "Define setting > Template settings".
But when I click on this link, I have a popup that just allow me to select the template again. And another link "More..." that redirects me to another popup that allows me to import a template.

It is normal that templates just contain shema and view json files (option for the 2 column template).

Any help would be very appreciated.
Thanks in advance.

Antoine.
Jul 8, 2015 at 10:24 AM
Hi,

I saw discussions are close on codeplex, so I copy paste my reply

Hi,

I have upgraded openForm and openContent module. I don't have the error anymore, but I still don't able to set up a form.

I have downloaded the 2 forms you provide on http://www.openextensions.net

Once I have install a openForm module on a page, I choose a template and I click on "Define setting > Template settings".
But when I click on this link, I have a popup that just allow me to select the template again. And another link "More..." that redirects me to another popup that allows me to import a template.

It is normal that templates just contain shema and view json files (option for the 2 column template).

Any help would be very appreciated.
Thanks in advance.

Antoine.

2015-06-09 1:41 GMT+08:00 sachatrauwaen <[email removed]>:

From: sachatrauwaen

Hi,

In ny case the path is : C:\inetpub\wwwroot__DNN731__\\Portals\1\OpenForm\Templates\Contact\schema.json
It only works for website directly install on wwwroot ?
No.
Do import the template ?
Does "C:\inetpub\wwwroot__DNN731__\\Portals\1\OpenForm\Templates\Contact\schema.json" the file and directory exist on your system ?

On the documentation tab, you wrote :
3) Add the OpenContent module to a page. Shoulb be : 3) Add the OpenForm module to a page, no ?
You are rigth. I have correct it.
Sacha

Read the full discussion online.

To add a post to this discussion, reply to this email ([email removed])

To start a new discussion for this project, email [email removed]

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Jul 8, 2015 at 10:27 AM
When I go to "Edit template", for "Data Definition" the path is "/Portals/0/OpenForm/Templates/Contact2Columns/schema.json" but in my case (local website) it should be
"/DNN731/Portals/0/OpenForm/Templates/Contact2Columns/schema.json"

2015-07-08 17:24 GMT+08:00 Antoine Laplante <[email removed]>:
Hi,

I saw discussions are close on codeplex, so I copy paste my reply

Hi,

I have upgraded openForm and openContent module. I don't have the error anymore, but I still don't able to set up a form.

I have downloaded the 2 forms you provide on http://www.openextensions.net

Once I have install a openForm module on a page, I choose a template and I click on "Define setting > Template settings".
But when I click on this link, I have a popup that just allow me to select the template again. And another link "More..." that redirects me to another popup that allows me to import a template.

It is normal that templates just contain shema and view json files (option for the 2 column template).

Any help would be very appreciated.
Thanks in advance.

Antoine.

2015-06-09 1:41 GMT+08:00 sachatrauwaen <[email removed]>:

From: sachatrauwaen

Hi,

In ny case the path is : C:\inetpub\wwwroot__DNN731__\\Portals\1\OpenForm\Templates\Contact\schema.json
It only works for website directly install on wwwroot ?
No.
Do import the template ?
Does "C:\inetpub\wwwroot__DNN731__\\Portals\1\OpenForm\Templates\Contact\schema.json" the file and directory exist on your system ?

On the documentation tab, you wrote :
3) Add the OpenContent module to a page. Shoulb be : 3) Add the OpenForm module to a page, no ?
You are rigth. I have correct it.
Sacha

Read the full discussion online.

To add a post to this discussion, reply to this email ([email removed])

To start a new discussion for this project, email [email removed]

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com



Jul 10, 2015 at 1:59 PM
Hi Antoine,
Normally when you chose a template and click save the form appears .

I Will check if there is an issue when, like you ,dnn is notre installed un the root of thé web site.

I come Next monday trop holyday

Regards
Sacha